aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4e363c9..e56757d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,13 +61,16 @@ endforeach()
include_directories("include")
# Build and install shared library with headers.
-add_library(nsmc SHARED ${C_SOURCES})
+add_library(nsmc SHARED extent-sampling.c gaussian-nd-random.c integrands.c nd-random.c oracles.c utils.c)
target_link_libraries(nsmc -lgsl -lgslcblas)
set_target_properties(nsmc PROPERTIES
PUBLIC_HEADER "include/extent-sampling.h;include/gaussian-nd-random.h;include/nd-random.h;include/oracles.h")
install(TARGETS nsmc LIBRARY
PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/nsmc)
+# Build executables
+add_executable(integral integral.c)
+target_link_libraries(integral nsmc -lm)
# Build and install scheme wrapper.
if(${GUILE_FOUND})
configure_file(scm/nsmc/load-libs.scm.in scm/nsmc/load-libs.scm)