aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArun Isaac2021-05-07 17:16:30 +0530
committerArun Isaac2021-05-07 17:16:30 +0530
commit3df13fea1c3b585910437dc2e787bfabebfed163 (patch)
tree35c53315bb1ba9b60f4c11365148445825d663a2 /CMakeLists.txt
parentf75010b875d19c8cf5e88f64a54efa033f3466b1 (diff)
downloadnsmc-3df13fea1c3b585910437dc2e787bfabebfed163.tar.gz
nsmc-3df13fea1c3b585910437dc2e787bfabebfed163.tar.lz
nsmc-3df13fea1c3b585910437dc2e787bfabebfed163.zip
Implement integral experiments.
* src/integral.sc: New file. * CMakeLists.txt: Explicitly specify sources for nsmc library. Add integral executable.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4e363c9..e56757d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,13 +61,16 @@ endforeach()
include_directories("include")
# Build and install shared library with headers.
-add_library(nsmc SHARED ${C_SOURCES})
+add_library(nsmc SHARED extent-sampling.c gaussian-nd-random.c integrands.c nd-random.c oracles.c utils.c)
target_link_libraries(nsmc -lgsl -lgslcblas)
set_target_properties(nsmc PROPERTIES
PUBLIC_HEADER "include/extent-sampling.h;include/gaussian-nd-random.h;include/nd-random.h;include/oracles.h")
install(TARGETS nsmc LIBRARY
PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/nsmc)
+# Build executables
+add_executable(integral integral.c)
+target_link_libraries(integral nsmc -lm)
# Build and install scheme wrapper.
if(${GUILE_FOUND})
configure_file(scm/nsmc/load-libs.scm.in scm/nsmc/load-libs.scm)