aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArun Isaac2021-05-07 17:17:43 +0530
committerArun Isaac2021-05-07 17:17:43 +0530
commitd90f2982c2de41dee7dd91c20698b4c30085eeb3 (patch)
tree7a0994dae8d3111b91e5989b00dbbc6dcae23790 /CMakeLists.txt
parent3df13fea1c3b585910437dc2e787bfabebfed163 (diff)
downloadnsmc-d90f2982c2de41dee7dd91c20698b4c30085eeb3.tar.gz
nsmc-d90f2982c2de41dee7dd91c20698b4c30085eeb3.tar.lz
nsmc-d90f2982c2de41dee7dd91c20698b4c30085eeb3.zip
Implement volume of bodies experiments.
* src/volume-bodies.sc: New file. * CMakeLists.txt: Add volume-bodies executable.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e56757d..ad0bc1f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,6 +69,8 @@ install(TARGETS nsmc LIBRARY
PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/nsmc)
# Build executables
+add_executable(volume-bodies volume-bodies.c)
+target_link_libraries(volume-bodies nsmc)
add_executable(integral integral.c)
target_link_libraries(integral nsmc -lm)
# Build and install scheme wrapper.