aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArun Isaac2021-05-07 17:18:25 +0530
committerArun Isaac2021-05-07 17:18:25 +0530
commit7ec6e79a83868fb618b844f7eb46a693c3f021e1 (patch)
treee73b3cf4d087d85693dd01481bdff5d16969c2dc /CMakeLists.txt
parentd90f2982c2de41dee7dd91c20698b4c30085eeb3 (diff)
downloadnsmc-7ec6e79a83868fb618b844f7eb46a693c3f021e1.tar.gz
nsmc-7ec6e79a83868fb618b844f7eb46a693c3f021e1.tar.lz
nsmc-7ec6e79a83868fb618b844f7eb46a693c3f021e1.zip
Implement spheroid importance sampling experiments.
* src/spheroid.sc: New file. * CMakeLists.txt: Add spheroid executable.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ad0bc1f..b4fae28 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,6 +73,9 @@ add_executable(volume-bodies volume-bodies.c)
target_link_libraries(volume-bodies nsmc)
add_executable(integral integral.c)
target_link_libraries(integral nsmc -lm)
+add_executable(spheroid spheroid.c)
+target_link_libraries(spheroid nsmc)
+
# Build and install scheme wrapper.
if(${GUILE_FOUND})
configure_file(scm/nsmc/load-libs.scm.in scm/nsmc/load-libs.scm)