aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2018-09-11 22:39:40 +0530
committerArun Isaac2018-09-11 22:50:19 +0530
commit4bc18f4e24318c860481df4fb3c243cc205ef03f (patch)
tree2402c80659e465e78ab0eaf9e89648d150f9658a /Makefile.am
parent7a6b266810bfd76e14d0d593d47a45c9caa44d7b (diff)
downloadguile-email-4bc18f4e24318c860481df4fb3c243cc205ef03f.tar.gz
guile-email-4bc18f4e24318c860481df4fb3c243cc205ef03f.tar.lz
guile-email-4bc18f4e24318c860481df4fb3c243cc205ef03f.zip
tests: Add tests for (email quoted-printable).
* build-aux/test-driver.scm: New file. * tests/quoted-printable.scm: New file. * Makefile.am (TEST_EXTENSIONS, SCM_TESTS, TESTS, SCM_LOG_DRIVER): New variables. (EXTRA_DIST): Register new files for distribution.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f4d352e..9b999e1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,5 +47,19 @@ SOURCES = \
email/quoted-printable.scm \
email/utils.scm
+TEST_EXTENSIONS = .scm
+
+SCM_TESTS = \
+ tests/quoted-printable.scm
+
+TESTS = $(SCM_TESTS)
+
+SCM_LOG_DRIVER = \
+ $(top_builddir)/pre-inst-env \
+ $(GUILE) --no-auto-compile -s \
+ $(top_builddir)/build-aux/test-driver.scm
+
EXTRA_DIST += \
+ $(TESTS) \
+ build-aux/test-driver.scm \
COPYING