aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2018-09-08 21:40:26 +0530
committerArun Isaac2018-09-08 21:40:26 +0530
commit7a6b266810bfd76e14d0d593d47a45c9caa44d7b (patch)
tree4359ac8968f4c88b253b76f81a066caf3a179c32 /Makefile.am
parent277a836aa2e9fca708b8860533ef68227a4c9308 (diff)
downloadguile-email-7a6b266810bfd76e14d0d593d47a45c9caa44d7b.tar.gz
guile-email-7a6b266810bfd76e14d0d593d47a45c9caa44d7b.tar.lz
guile-email-7a6b266810bfd76e14d0d593d47a45c9caa44d7b.zip
Set up the GNU build system.
* Makefile.am, bootstrap.sh, configure.ac, pre-inst-env.in: New files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..f4d352e
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,51 @@
+# guile-email --- Guile email parser
+# Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+# Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+#
+# This file was adapted from mumi and is part of guile-email.
+#
+# guile-email is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as
+# published by the Free Software Foundation; either version 3 of the
+# License, or (at your option) any later version.
+#
+# guile-email is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public
+# License along with guile-email. If not, see
+# <http://www.gnu.org/licenses/>.
+
+GOBJECTS = $(SOURCES:%.scm=%.go)
+
+nobase_mod_DATA = $(SOURCES) $(NOCOMP_SOURCES)
+nobase_go_DATA = $(GOBJECTS)
+
+# Make sure source files are installed first, so that the mtime of
+# installed compiled files is greater than that of installed source
+# files. See
+# <http://lists.gnu.org/archive/html/guile-devel/2010-07/msg00125.html>
+# for details.
+guile_install_go_files = install-nobase_goDATA
+$(guile_install_go_files): install-nobase_modDATA
+
+CLEANFILES = $(GOBJECTS)
+EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
+GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
+SUFFIXES = .scm .go
+.scm.go:
+ $(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
+
+moddir = $(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
+godir = $(moddir)
+
+SOURCES = \
+ email/base64.scm \
+ email/email.scm \
+ email/quoted-printable.scm \
+ email/utils.scm
+
+EXTRA_DIST += \
+ COPYING