aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPeter Amstutz2020-04-06 14:11:41 -0400
committerPeter Amstutz2020-04-06 14:11:41 -0400
commit2c69ca48ce1a9ab431afcc891bdad8c495c9768e (patch)
treee761e2205110e3bd4278807a96d8f178bc41da00 /setup.py
parentfd137721188b0044b9259b3a9aed14c155477888 (diff)
downloadbh20-seq-resource-2c69ca48ce1a9ab431afcc891bdad8c495c9768e.tar.gz
bh20-seq-resource-2c69ca48ce1a9ab431afcc891bdad8c495c9768e.tar.lz
bh20-seq-resource-2c69ca48ce1a9ab431afcc891bdad8c495c9768e.zip
Add service to automatically run a workflow on collections uploaded to a project.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index d5c71b2..9e73ff0 100644
--- a/setup.py
+++ b/setup.py
@@ -29,13 +29,14 @@ setup(
author="Peter Amstutz",
author_email="peter.amstutz@curii.com",
license="Apache 2.0",
- packages=["bh20sequploader"],
+ packages=["bh20sequploader", "bh20seqanalyzer"],
install_requires=install_requires,
setup_requires=[] + pytest_runner,
tests_require=["pytest<5"],
entry_points={
"console_scripts": [
- "bh20-seq-uploader=bh20sequploader.main:main"
+ "bh20-seq-uploader=bh20sequploader.main:main",
+ "bh20-seq-analyzer=bh20seqanalyzer.main:main"
]
},
zip_safe=True,