aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPjotr Prins2020-05-06 09:03:08 -0500
committerPjotr Prins2020-05-06 09:03:08 -0500
commit0031e778ee1ad8b934411da5082fcb3115646e67 (patch)
treebe17fb9aff6351e967a9210cd4c58a60ad55a382 /setup.py
parent7d7af6cde75d09da7a05cf5bc05ef2556c3aea92 (diff)
parentb6d846b5de6c67b28adab1fa520953115a1a1e30 (diff)
downloadbh20-seq-resource-0031e778ee1ad8b934411da5082fcb3115646e67.tar.gz
bh20-seq-resource-0031e778ee1ad8b934411da5082fcb3115646e67.tar.lz
bh20-seq-resource-0031e778ee1ad8b934411da5082fcb3115646e67.zip
Merge branch 'master' of github.com:arvados/bh20-seq-resource
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 4ab6329..412c103 100644
--- a/setup.py
+++ b/setup.py
@@ -15,7 +15,8 @@ try:
except ImportError:
tagger = egg_info_cmd.egg_info
-install_requires = ["arvados-python-client", "schema-salad", "python-magic", "pyshex"]
+install_requires = ["arvados-python-client", "schema-salad",
+ "python-magic", "pyshex", "py-dateutil"]
web_requires = ["flask", "pyyaml"]
needs_pytest = {"pytest", "test", "ptr"}.intersection(sys.argv)
@@ -26,7 +27,7 @@ setup(
version="1.0",
description="Biohackathon sequence uploader",
long_description=open(README).read(),
- long_description_content_type="text/x-rst",
+ long_description_content_type="text/markdown",
author="Peter Amstutz",
author_email="peter.amstutz@curii.com",
license="Apache 2.0",
@@ -34,7 +35,8 @@ setup(
package_data={"bh20sequploader": ["bh20seq-schema.yml",
"bh20seq-options.yml",
"bh20seq-shex.rdf",
- "validation/formats"],
+ "validation/formats",
+ "SARS-CoV-2-reference.fasta",],
},
install_requires=install_requires,
extras_require={