aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b26700f..8ba7637 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -3,8 +3,11 @@ TESTS_ENVIRONMENT = \
GUILE_LOAD_COMPILED_PATH="$(top_builddir)/src/guile:$$GUILE_LOAD_COMPILED_PATH"; \
export GUILE_AUTO_COMPILE GUILE_LOAD_COMPILED_PATH;
-TEST_LOG_COMPILER = \
- $(GUILE) -L $(top_srcdir)/src/guile -L $(top_builddir)/src/guile
+TEST_LOG_DRIVER = \
+ $(GUILE) --no-auto-compile -e main \
+ -L "$(top_srcdir)/src/guile" -L "$(top_builddir)/src/guile" \
+ -L "$(srcdir)" \
+ "$(top_srcdir)/build-aux/test-driver.scm"
TESTS = \
ast.test \