aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès2021-09-29 18:21:19 +0200
committerLudovic Courtès2021-09-29 18:26:39 +0200
commit671e55bb3bbbb3467dee5d6e438ea897acda814e (patch)
treea74d75536f01fd0a2bf1a6e30be222a543aa1e47 /tests/Makefile.am
parent632ff359c089892d55a15d29e7931bf0ce255d8e (diff)
downloadskribilo-671e55bb3bbbb3467dee5d6e438ea897acda814e.tar.gz
skribilo-671e55bb3bbbb3467dee5d6e438ea897acda814e.tar.lz
skribilo-671e55bb3bbbb3467dee5d6e438ea897acda814e.zip
build: Use SRFI-64 test suite driver as found in Guix.
This works around the fact that SRFI-64 in Guile 3.0.6+, 'test-runner-current' returns #f after 'test-end'. It also gives us a more featureful test runner, where one can do things like: make check TEST_LOG_DRIVER_FLAGS="--brief=no --show-duration=yes" Reported by <soeren@soeren-tempel.net>. * build-aux/test-driver.scm: New file. * Makefile.am (EXTRA_DIST): Add it. * tests/Makefile.am (TEST_LOG_DRIVER): New variable. (TEST_LOG_COMPILER): New variable. * tests/ast.test, tests/engines/info.test, tests/location.test, tests/readers/rss-2.test, tests/resolve.test: Remove call to 'exit'.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b26700f..8ba7637 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -3,8 +3,11 @@ TESTS_ENVIRONMENT = \
GUILE_LOAD_COMPILED_PATH="$(top_builddir)/src/guile:$$GUILE_LOAD_COMPILED_PATH"; \
export GUILE_AUTO_COMPILE GUILE_LOAD_COMPILED_PATH;
-TEST_LOG_COMPILER = \
- $(GUILE) -L $(top_srcdir)/src/guile -L $(top_builddir)/src/guile
+TEST_LOG_DRIVER = \
+ $(GUILE) --no-auto-compile -e main \
+ -L "$(top_srcdir)/src/guile" -L "$(top_builddir)/src/guile" \
+ -L "$(srcdir)" \
+ "$(top_srcdir)/build-aux/test-driver.scm"
TESTS = \
ast.test \