aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArun Isaac2021-02-10 14:28:32 +0530
committerArun Isaac2021-02-10 14:53:50 +0530
commitfc2a0c2aba0a8526412869349683cb04f1038465 (patch)
tree57b947dab3d31db61f3b645795db9729cb7f4aec /CMakeLists.txt
parent7b74734e6b9356cf4208950ba254b75d756aec5b (diff)
downloadnsmc-fc2a0c2aba0a8526412869349683cb04f1038465.tar.gz
nsmc-fc2a0c2aba0a8526412869349683cb04f1038465.tar.lz
nsmc-fc2a0c2aba0a8526412869349683cb04f1038465.zip
Add pre-installation environment script.
The pre-inst-env script is required to find freshly built libraries and scheme files before installation. * pre-inst-env.in: New file. * CMakeLists.txt: Configure pre-inst-env.in with correct paths.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index beae2ff..5c0adf2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,3 +69,6 @@ if(${GUILE_FOUND})
install(FILES ${CMAKE_BINARY_DIR}/${SCM_WRAPPER_GO_PATH}
DESTINATION ${CMAKE_INSTALL_LIBDIR}/guile/site/${GUILE_MAJOR_VERSION}.${GUILE_MINOR_VERSION}/site-ccache/extent-sampling)
endif()
+
+# Configure environment wrapper script.
+configure_file(pre-inst-env.in pre-inst-env @ONLY)