aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArun Isaac2021-02-11 14:32:22 +0530
committerArun Isaac2021-02-11 14:32:22 +0530
commitf6be32b56059d439b13d704815b040eb62d4dc5e (patch)
tree4f5d0d117366311af22f0071e880a3217424abda /CMakeLists.txt
parent1f847944d8769579fb5a351cdf1232f95370e7a7 (diff)
downloadnsmc-f6be32b56059d439b13d704815b040eb62d4dc5e.tar.gz
nsmc-f6be32b56059d439b13d704815b040eb62d4dc5e.tar.lz
nsmc-f6be32b56059d439b13d704815b040eb62d4dc5e.zip
Link libextentsampling with libgsl and libgslcblas.
* CMakeLists.txt: Link libextentsampling with libgsl and libgslcblas.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c0adf2..fc926c6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,6 +42,7 @@ include_directories("include")
include(GNUInstallDirs)
add_library(extentsampling SHARED ${C_SOURCES})
+target_link_libraries(extentsampling -lgsl -lgslcblas)
set_target_properties(extentsampling PROPERTIES
PUBLIC_HEADER "include/extent-sampling.h;include/gaussian-nd-random.h;include/nd-random.h;include/oracles.h")
install(TARGETS extentsampling LIBRARY