aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArun Isaac2021-02-09 18:11:57 +0530
committerArun Isaac2021-02-09 18:11:57 +0530
commite3cdcaf807ff3833f2a9ef642301bcaa3172a8ad (patch)
tree620253813e4fe1e27262a8799e04c0e736ba7f57 /CMakeLists.txt
parentd88045a3b7c592d07c168d1bca060e3e26d61b73 (diff)
downloadnsmc-e3cdcaf807ff3833f2a9ef642301bcaa3172a8ad.tar.gz
nsmc-e3cdcaf807ff3833f2a9ef642301bcaa3172a8ad.tar.lz
nsmc-e3cdcaf807ff3833f2a9ef642301bcaa3172a8ad.zip
Install headers and shared library.
* CMakeLists.txt: Install headers and shared library.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 360b931..935c3b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,4 +30,10 @@ endforeach()
include_directories("include")
+include(GNUInstallDirs)
+
add_library(extentsampling SHARED ${C_SOURCES})
+set_target_properties(extentsampling PROPERTIES
+ PUBLIC_HEADER "include/extent-sampling.h;include/gaussian-nd-random.h;include/nd-random.h;include/oracles.h")
+install(TARGETS extentsampling LIBRARY
+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/extent-sampling)