aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArun Isaac2021-02-26 16:09:24 +0530
committerArun Isaac2021-02-26 16:09:24 +0530
commitbf16c2d00fbcfb8cdb092ee95d09f5181fcaf1b7 (patch)
tree43743e91454b2c252b1ea0e2ccbad25ab8b71a2d /CMakeLists.txt
parent94d735868847bb61c16bfc33131100a74e04d30a (diff)
downloadnsmc-bf16c2d00fbcfb8cdb092ee95d09f5181fcaf1b7.tar.gz
nsmc-bf16c2d00fbcfb8cdb092ee95d09f5181fcaf1b7.tar.lz
nsmc-bf16c2d00fbcfb8cdb092ee95d09f5181fcaf1b7.zip
Include GNUInstallDirs earlier in CMakeLists.
* CMakeLists.txt: Include GNUInstallDirs earlier.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc926c6..4aeba53 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,8 @@ find_program(INDENT NAMES indent)
pkg_check_modules(GUILE guile-3.0)
pkg_get_variable(GUILD guile-3.0 guild)
+include(GNUInstallDirs)
+
function(change_extension var filename extension)
get_filename_component(basename ${filename} NAME_WE)
get_filename_component(dirname ${filename} DIRECTORY)
@@ -39,8 +41,6 @@ endforeach()
include_directories("include")
-include(GNUInstallDirs)
-
add_library(extentsampling SHARED ${C_SOURCES})
target_link_libraries(extentsampling -lgsl -lgslcblas)
set_target_properties(extentsampling PROPERTIES