aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArun Isaac2021-02-05 15:34:26 +0530
committerArun Isaac2021-02-05 15:34:26 +0530
commita8cc65dc659834e4bf0c9508b327e62e52ad6644 (patch)
tree26978a9cc7e927a3d128b1a889b7e834dc4a474b /CMakeLists.txt
parentda3c8cb71c57ec1b3a44d63064e15cc57035f98c (diff)
downloadnsmc-a8cc65dc659834e4bf0c9508b327e62e52ad6644.tar.gz
nsmc-a8cc65dc659834e4bf0c9508b327e62e52ad6644.tar.lz
nsmc-a8cc65dc659834e4bf0c9508b327e62e52ad6644.zip
Specify dependency on src/macros/macros.sc.
Not all SC files need depend on src/macros/macros.sc, but we make this simplifying assumption so as to not have to scan the source files at build time. * CMakeLists.txt: Make every SC file depend on src/macros/macros.sc.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae19f92..168eb01 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,7 +15,7 @@ foreach(sc_source ${SC_SOURCES})
OUTPUT ${c_file}
COMMAND ${SC} ${sc_source} ${c_file}
COMMAND ${INDENT} ${c_file}
- DEPENDS ${sc_source}
+ DEPENDS ${sc_source} src/macros/macros.sc
VERBATIM)
list(APPEND C_SOURCES ${c_file})
endforeach()