aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArun Isaac2021-02-26 21:07:45 +0530
committerArun Isaac2021-02-26 21:13:07 +0530
commit8f3d10e53b598e87f6308727bc61c90ed43f2726 (patch)
treed780e122a4e689fc5189798aa9f521ea2d776f7d /CMakeLists.txt
parent720c62ae094fa17f49fcfe215b351d80a0e77464 (diff)
downloadnsmc-8f3d10e53b598e87f6308727bc61c90ed43f2726.tar.gz
nsmc-8f3d10e53b598e87f6308727bc61c90ed43f2726.tar.lz
nsmc-8f3d10e53b598e87f6308727bc61c90ed43f2726.zip
Add copyright and license headers for all files.
* include/extent-sampling.h, include/gaussian-nd-random.h, include/integrands.h, include/nd-random.h, include/oracles.h, include/utils.h, src/extent-sampling.sc, src/gaussian-nd-random.sc, src/integrands.sc, src/macros/macros.sc, src/nd-random.sc, src/oracles.sc, src/utils.sc, CMakeLists.txt, pre-inst-env.in: Add copyright and license headers.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce1be04..4e363c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,22 @@
+# nsmc --- n-sphere Monte Carlo method
+# Copyright © 2021 Arun I <arunisaac@systemreboot.net>
+# Copyright © 2021 Murugesan Venkatapathi <murugesh@iisc.ac.in>
+#
+# This file is part of nsmc.
+#
+# nsmc is free software: you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# nsmc is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with nsmc. If not, see <https://www.gnu.org/licenses/>.
+
cmake_minimum_required(VERSION 3.10)
project(nsmc VERSION 0.1.0)