aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArun Isaac2021-02-03 14:58:23 +0530
committerArun Isaac2021-02-03 14:58:23 +0530
commit707afdfe66dd9c931af77e4ff73186fd89ed27fd (patch)
treea30f0592da7b91c17e1a7ce4716c7a02cfc5dbaa /CMakeLists.txt
parentac33f97e8bc2262939339de704e267a29aa1f7a3 (diff)
downloadnsmc-707afdfe66dd9c931af77e4ff73186fd89ed27fd.tar.gz
nsmc-707afdfe66dd9c931af77e4ff73186fd89ed27fd.tar.lz
nsmc-707afdfe66dd9c931af77e4ff73186fd89ed27fd.zip
Set up a cmake build system.
* Makefile: Delete file. * CMakeLists.txt: New file.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..01639b2
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,7 @@
+cmake_minimum_required(VERSION 3.10)
+project(extent-sampling VERSION 0.1)
+
+find_package(GSL REQUIRED)
+
+file(GLOB SOURCES "*.c")
+add_library(extentsampling SHARED ${SOURCES})