aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorArun Isaac2022-03-20 18:50:08 +0530
committerArun Isaac2022-03-20 19:05:17 +0530
commit25c04ddf9dc18ffcec2aeb8d031dc0085e323057 (patch)
tree9b0d72ee8b7d5d9ab674e92ec16bd8d1921aa9c9 /Makefile
parent1c2ed989e5f5645814de67a767a6581e57bebf41 (diff)
downloadguix-forge-25c04ddf9dc18ffcec2aeb8d031dc0085e323057.tar.gz
guix-forge-25c04ddf9dc18ffcec2aeb8d031dc0085e323057.tar.lz
guix-forge-25c04ddf9dc18ffcec2aeb8d031dc0085e323057.zip
website: Use Charter as main body font.
* Makefile (fonts): New variable. (website/fonts): New target. (website): Depend on website/fonts. (clean): Clean website/fonts. * website/style.css (@font-face: Charter): New font face. (body): Set font-family to Charter. Set font-size to 20px. * .gitignore: Add website/fonts.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index c2f932a..1b71874 100644
--- a/Makefile
+++ b/Makefile
@@ -26,6 +26,7 @@ doc_skribilo_config_go = $(doc_skribilo_config:.scm=.go)
doc_sources = doc/forge.skb
doc_snippets = $(wildcard doc/snippets/*.scm)
doc_html = $(doc_sources:.skb=.html)
+fonts = $(addprefix $(GUIX_ENVIRONMENT)/share/fonts/web/, charter_regular.woff2)
.PHONY: all html clean
all: ;
@@ -40,7 +41,7 @@ $(doc_html): $(doc_sources) $(doc_snippets) $(sources) $(doc_skribilo_config_go)
mkdir -p $@
GUILE_LOAD_PATH=$(CURDIR):$(GUILE_LOAD_PATH) GUILE_LOAD_COMPILED_PATH=$(CURDIR):$(GUILE_LOAD_COMPILED_PATH) $(SKRIBILO) --target=html $< --output=$@/index.html
-website: website/index.html website/manual/dev/en
+website: website/index.html website/manual/dev/en website/fonts
website/index.html: README.org build-aux/build-home-page.el
$(EMACS) -Q --batch --load build-aux/build-home-page.el --funcall build-website
@@ -50,5 +51,10 @@ website/manual/dev/en: $(doc_html)
mkdir -p $(dir $@)
cp -vr $^ $@
+website/fonts: $(fonts)
+ rm -rf $@
+ mkdir -p $@
+ cp -v $^ $@/
+
clean:
- rm -rf $(doc_skribilo_config_go) website/index.html website/manual
+ rm -rf $(doc_skribilo_config_go) website/index.html website/manual website/fonts