aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--Makefile10
-rw-r--r--website/style.css10
3 files changed, 18 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index 6836cf9..aaef8b4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
doc/*.go
doc/*.html
+website/fonts
website/index.html
website/manual \ No newline at end of file
diff --git a/Makefile b/Makefile
index c2f932a..1b71874 100644
--- a/Makefile
+++ b/Makefile
@@ -26,6 +26,7 @@ doc_skribilo_config_go = $(doc_skribilo_config:.scm=.go)
doc_sources = doc/forge.skb
doc_snippets = $(wildcard doc/snippets/*.scm)
doc_html = $(doc_sources:.skb=.html)
+fonts = $(addprefix $(GUIX_ENVIRONMENT)/share/fonts/web/, charter_regular.woff2)
.PHONY: all html clean
all: ;
@@ -40,7 +41,7 @@ $(doc_html): $(doc_sources) $(doc_snippets) $(sources) $(doc_skribilo_config_go)
mkdir -p $@
GUILE_LOAD_PATH=$(CURDIR):$(GUILE_LOAD_PATH) GUILE_LOAD_COMPILED_PATH=$(CURDIR):$(GUILE_LOAD_COMPILED_PATH) $(SKRIBILO) --target=html $< --output=$@/index.html
-website: website/index.html website/manual/dev/en
+website: website/index.html website/manual/dev/en website/fonts
website/index.html: README.org build-aux/build-home-page.el
$(EMACS) -Q --batch --load build-aux/build-home-page.el --funcall build-website
@@ -50,5 +51,10 @@ website/manual/dev/en: $(doc_html)
mkdir -p $(dir $@)
cp -vr $^ $@
+website/fonts: $(fonts)
+ rm -rf $@
+ mkdir -p $@
+ cp -v $^ $@/
+
clean:
- rm -rf $(doc_skribilo_config_go) website/index.html website/manual
+ rm -rf $(doc_skribilo_config_go) website/index.html website/manual website/fonts
diff --git a/website/style.css b/website/style.css
index 01c655e..5d8415c 100644
--- a/website/style.css
+++ b/website/style.css
@@ -1,8 +1,16 @@
+@font-face {
+ font-family: 'Charter';
+ src: url('/fonts/charter_regular.woff2') format('woff2');
+ font-weight: normal;
+ font-style: normal;
+}
+
body {
margin: 40px auto;
max-width: 900px;
line-height: 1.6;
- font-size: 18px;
+ font-family: 'Charter';
+ font-size: 20px;
padding: 0 10px;
}