aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b5f954f..6417ce9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -54,7 +54,7 @@ nobase_mod_DATA = $(SOURCES)
nobase_go_DATA = $(GOBJECTS)
CLEANFILES = $(GOBJECTS)
-EXTRA_DIST = $(SOURCES)
+
GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
SUFFIXES = .scm .go
.scm.go:
@@ -64,6 +64,21 @@ SUFFIXES = .scm .go
# shared library.
xapian/xapian.go: xapian/xapian.scm libguilexapian.la
+# Tests
+
+TEST_EXTENSIONS = .scm
+SCM_TESTS = tests/xapian.scm
+TESTS = $(SCM_TESTS)
+
+SCM_LOG_DRIVER = \
+ $(builddir)/pre-inst-env \
+ $(GUILE) --no-auto-compile -s \
+ $(builddir)/build-aux/test-driver.scm
+
+# Distribution
+
+EXTRA_DIST = $(TESTS) $(SOURCES)
+
# Build website
website: website/index.html