aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-09-07 00:50:54 +0530
committerArun Isaac2021-09-07 00:55:12 +0530
commite95d5405593176df126d0b5d0c83d4ce71f4ac24 (patch)
tree380b327c6eb2c6b5fa698bd6586d897363d86b50 /Makefile.am
parent22c8e5d33d17f54496d5e44c98a024c46155eb5b (diff)
downloadguile-xapian-e95d5405593176df126d0b5d0c83d4ce71f4ac24.tar.gz
guile-xapian-e95d5405593176df126d0b5d0c83d4ce71f4ac24.tar.lz
guile-xapian-e95d5405593176df126d0b5d0c83d4ce71f4ac24.zip
Set up testing infrastructure.
* tests/xapian.scm: New file. * build-aux/test-driver.scm.in: New file. * configure.ac: Configure build-aux/test-driver.scm. * .gitignore: Add build-aux/test-driver.scm, tests/*.log and tests/*.trs. * Makefile.am (EXTRA_DIST): Add TESTS. (TEST_EXTENSIONS, SCM_TESTS, TESTS, SCM_LOG_DRIVER): New variables.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b5f954f..6417ce9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -54,7 +54,7 @@ nobase_mod_DATA = $(SOURCES)
nobase_go_DATA = $(GOBJECTS)
CLEANFILES = $(GOBJECTS)
-EXTRA_DIST = $(SOURCES)
+
GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
SUFFIXES = .scm .go
.scm.go:
@@ -64,6 +64,21 @@ SUFFIXES = .scm .go
# shared library.
xapian/xapian.go: xapian/xapian.scm libguilexapian.la
+# Tests
+
+TEST_EXTENSIONS = .scm
+SCM_TESTS = tests/xapian.scm
+TESTS = $(SCM_TESTS)
+
+SCM_LOG_DRIVER = \
+ $(builddir)/pre-inst-env \
+ $(GUILE) --no-auto-compile -s \
+ $(builddir)/build-aux/test-driver.scm
+
+# Distribution
+
+EXTRA_DIST = $(TESTS) $(SOURCES)
+
# Build website
website: website/index.html