aboutsummaryrefslogtreecommitdiff
path: root/guix.scm
diff options
context:
space:
mode:
authorArun Isaac2023-01-03 16:55:56 +0000
committerArun Isaac2023-01-03 17:43:28 +0000
commit7bef05430de5e39bf2937b026d68d63116c46233 (patch)
tree9cc5c384bab5d251ce86eb83b4c47c388684008b /guix.scm
parentfcc36808753a95ae8f6826c102a632a5a395d245 (diff)
downloadguile-email-7bef05430de5e39bf2937b026d68d63116c46233.tar.gz
guile-email-7bef05430de5e39bf2937b026d68d63116c46233.tar.lz
guile-email-7bef05430de5e39bf2937b026d68d63116c46233.zip
Quit the autotools build system.
For a simple package like guile-email, the autotools build system is more trouble than it is worth. We prefer a hand-written Makefile. As the commit summary suggests, the autotools are indeed a bad habit that we must "quit". * Makefile: New file. * Makefile.am, bootstrap.sh, configure.ac, pre-inst-env.in: Delete files. * build-aux/test-corpus.scm.in: Rename to ... * build-aux/test-corpus.scm: ... this. Remove shebang. * build-aux/test-driver.scm.in: Rename to ... * build-aux/test-driver.scm: ... this. Remove autotools specific parts. * guix.scm: Import (guix utils). (guile-email)[arguments]: Add prefix to #:make-flags. Delete configure phase. * .gitignore: Remove INSTALL, Makefile, Makefile.in, aclocal.m4, autom4te.cache, build-aux/install-sh, build-aux/missing, build-aux/test-corpus.scm, config.log, config.status, configure, doc/.dirstamp, pre-inst-env, test-suite.log, tests/*.log and tests/*.trs.
Diffstat (limited to 'guix.scm')
-rw-r--r--guix.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/guix.scm b/guix.scm
index f9d8c2d..ba84870 100644
--- a/guix.scm
+++ b/guix.scm
@@ -25,6 +25,7 @@
(use-modules (guix gexp)
(guix git-download)
(guix packages)
+ (guix utils)
(gnu packages autotools)
(gnu packages guile-xyz)
(gnu packages texinfo))
@@ -36,6 +37,13 @@
(source (local-file %source-dir
#:recursive? #t
#:select? (git-predicate %source-dir)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments guile-email)
+ ((#:make-flags make-flags #~(list))
+ #~(list (string-append "prefix=" #$output)))
+ ((#:phases phases #~%standard-phases)
+ #~(modify-phases #$phases
+ (delete 'configure)))))
(native-inputs
(modify-inputs (package-native-inputs guile-email)
(prepend autoconf)