aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Isaac2018-09-08 21:40:26 +0530
committerArun Isaac2018-09-08 21:40:26 +0530
commit7a6b266810bfd76e14d0d593d47a45c9caa44d7b (patch)
tree4359ac8968f4c88b253b76f81a066caf3a179c32 /configure.ac
parent277a836aa2e9fca708b8860533ef68227a4c9308 (diff)
downloadguile-email-7a6b266810bfd76e14d0d593d47a45c9caa44d7b.tar.gz
guile-email-7a6b266810bfd76e14d0d593d47a45c9caa44d7b.tar.lz
guile-email-7a6b266810bfd76e14d0d593d47a45c9caa44d7b.zip
Set up the GNU build system.
* Makefile.am, bootstrap.sh, configure.ac, pre-inst-env.in: New files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..9297ac5
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,32 @@
+dnl guile-email --- Guile email parser
+dnl Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+dnl
+dnl This file is part of guile-email.
+dnl
+dnl guile-email is free software; you can redistribute it and/or modify
+dnl it under the terms of the GNU Affero General Public License as
+dnl published by the Free Software Foundation; either version 3 of the
+dnl License, or (at your option) any later version.
+dnl
+dnl guile-email is distributed in the hope that it will be useful, but
+dnl WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+dnl Affero General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU Affero General Public
+dnl License along with guile-email. If not, see
+dnl <http://www.gnu.org/licenses/>.
+
+AC_INIT([guile-email], [0.1])
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign])
+
+GUILE_PKG([2.2])
+GUILE_PROGS
+if test "x$GUILD" = "x"; then
+ AC_MSG_ERROR(['guild' binary not found; please check your guile-2.2 installation.])
+fi
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+AC_OUTPUT