aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2021-06-18 14:14:12 +0530
committerArun Isaac2021-06-18 14:14:12 +0530
commite4c81c5ce3459162d01f1ccd0e93f893a7c1ac6f (patch)
tree68ade88bada359d57fbe84030e971cd44887acb3 /Makefile.am
parent6440766cc193e45580eb3232ec3fcafd8257d9b6 (diff)
downloadguile-email-e4c81c5ce3459162d01f1ccd0e93f893a7c1ac6f.tar.gz
guile-email-e4c81c5ce3459162d01f1ccd0e93f893a7c1ac6f.tar.lz
guile-email-e4c81c5ce3459162d01f1ccd0e93f893a7c1ac6f.zip
website: Move releases into website directory.
If the releases directory is already in the website directory, then we don't need to redundantly copy it while building the website. * releases: Move to website/releases. * Makefile.am (website): Do not copy releases. (clean-local): Do not clean website/releases.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index f578418..6ff6a64 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
# guile-email --- Guile email parser
# Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
-# Copyright © 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
+# Copyright © 2018, 2019, 2021 Arun Isaac <arunisaac@systemreboot.net>
#
# This file was adapted from mumi and is part of guile-email.
#
@@ -72,14 +72,13 @@ EXTRA_DIST += \
COPYING \
README.org
-website: html releases website/index.html
+website: html website/index.html
mkdir -p website/manual/dev
cp -vr doc/guile-email.html website/manual/dev/en
- cp -vr releases website/
website/index.html: README.org
mkdir -p website
emacs -Q --script build-website.el
clean-local:
- rm -rf website
+ rm -rf website/index.html website/manual/dev/en