aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArun Isaac2019-06-22 21:25:58 +0530
committerArun Isaac2019-06-22 21:25:58 +0530
commit887e866bd319502403bd475a1870dd71a3c7f4df (patch)
treed71aeb97c83bf901ebc4e738b87ab8b50dbfef59 /Makefile.am
parentf4a4b26dd53723fbcf452c4af24df4834b06471a (diff)
downloadguile-email-887e866bd319502403bd475a1870dd71a3c7f4df.tar.gz
guile-email-887e866bd319502403bd475a1870dd71a3c7f4df.tar.lz
guile-email-887e866bd319502403bd475a1870dd71a3c7f4df.zip
Build website.
* Makefile.am (website, website/index.html): Add build targets. (clean-local): Add clean target. * build-website.el: New file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a0b3592..a8df177 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -67,3 +67,13 @@ EXTRA_DIST += \
build-aux/test-driver.scm \
COPYING \
README.org
+
+website: html website/index.html
+ cp -vr doc/guile-email.html website/manual
+
+website/index.html: README.org
+ mkdir -p website
+ emacs -Q --script build-website.el
+
+clean-local:
+ rm -rf website