aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPeter Amstutz2020-04-20 12:50:03 -0400
committerPeter Amstutz2020-04-20 12:50:03 -0400
commit1219eaf496c899f3043b90e30eb956f0f363bfb3 (patch)
treea0735d5df88e608c5461d5b3cb9a3c6bb2f0f32e /setup.py
parenta2d19fa7b34170abab3759cdff14d8b052178a8a (diff)
downloadbh20-seq-resource-1219eaf496c899f3043b90e30eb956f0f363bfb3.tar.gz
bh20-seq-resource-1219eaf496c899f3043b90e30eb956f0f363bfb3.tar.lz
bh20-seq-resource-1219eaf496c899f3043b90e30eb956f0f363bfb3.zip
Add ShEx validation
Arvados-DCO-1.1-Signed-off-by: Peter Amstutz <peter.amstutz@curii.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 0e91274..4ab6329 100644
--- a/setup.py
+++ b/setup.py
@@ -15,7 +15,7 @@ try:
except ImportError:
tagger = egg_info_cmd.egg_info
-install_requires = ["arvados-python-client", "schema-salad", "python-magic"]
+install_requires = ["arvados-python-client", "schema-salad", "python-magic", "pyshex"]
web_requires = ["flask", "pyyaml"]
needs_pytest = {"pytest", "test", "ptr"}.intersection(sys.argv)
@@ -31,7 +31,10 @@ setup(
author_email="peter.amstutz@curii.com",
license="Apache 2.0",
packages=["bh20sequploader", "bh20seqanalyzer", "bh20simplewebuploader"],
- package_data={"bh20sequploader": ["bh20seq-schema.yml", "bh20seq-options.yml", "validation/formats"],
+ package_data={"bh20sequploader": ["bh20seq-schema.yml",
+ "bh20seq-options.yml",
+ "bh20seq-shex.rdf",
+ "validation/formats"],
},
install_requires=install_requires,
extras_require={