aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPeter Amstutz2020-04-07 15:28:42 -0400
committerPeter Amstutz2020-04-07 15:28:42 -0400
commit07bc4c65535437b8e9e0744f08da8cea541d0116 (patch)
tree201cd544a87aebf0ba6978c42d61df1e90d7d836 /setup.py
parent4215a82af730ff05b8fe98e226b759413cdf95f7 (diff)
downloadbh20-seq-resource-07bc4c65535437b8e9e0744f08da8cea541d0116.tar.gz
bh20-seq-resource-07bc4c65535437b8e9e0744f08da8cea541d0116.tar.lz
bh20-seq-resource-07bc4c65535437b8e9e0744f08da8cea541d0116.zip
Add metadata validation with schema-salad
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0685d37..48c25aa 100644
--- a/setup.py
+++ b/setup.py
@@ -15,7 +15,7 @@ try:
except ImportError:
tagger = egg_info_cmd.egg_info
-install_requires = ["arvados-python-client"]
+install_requires = ["arvados-python-client", "schema-salad"]
needs_pytest = {"pytest", "test", "ptr"}.intersection(sys.argv)
pytest_runner = ["pytest < 6", "pytest-runner < 5"] if needs_pytest else []
@@ -30,6 +30,7 @@ setup(
author_email="peter.amstutz@curii.com",
license="Apache 2.0",
packages=["bh20sequploader", "bh20seqanalyzer"],
+ package_data={"bh20sequploader": ["bh20seq-schema.yml"]},
install_requires=install_requires,
setup_requires=[] + pytest_runner,
tests_require=["pytest<5"],