diff options
author | Peter Amstutz | 2020-04-20 12:50:03 -0400 |
---|---|---|
committer | Peter Amstutz | 2020-04-20 12:50:03 -0400 |
commit | 1219eaf496c899f3043b90e30eb956f0f363bfb3 (patch) | |
tree | a0735d5df88e608c5461d5b3cb9a3c6bb2f0f32e /setup.py | |
parent | a2d19fa7b34170abab3759cdff14d8b052178a8a (diff) | |
download | bh20-seq-resource-1219eaf496c899f3043b90e30eb956f0f363bfb3.tar.gz bh20-seq-resource-1219eaf496c899f3043b90e30eb956f0f363bfb3.tar.lz bh20-seq-resource-1219eaf496c899f3043b90e30eb956f0f363bfb3.zip |
Add ShEx validation
Arvados-DCO-1.1-Signed-off-by: Peter Amstutz <peter.amstutz@curii.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 7 |
1 files changed, 5 insertions, 2 deletions
@@ -15,7 +15,7 @@ try: except ImportError: tagger = egg_info_cmd.egg_info -install_requires = ["arvados-python-client", "schema-salad", "python-magic"] +install_requires = ["arvados-python-client", "schema-salad", "python-magic", "pyshex"] web_requires = ["flask", "pyyaml"] needs_pytest = {"pytest", "test", "ptr"}.intersection(sys.argv) @@ -31,7 +31,10 @@ setup( author_email="peter.amstutz@curii.com", license="Apache 2.0", packages=["bh20sequploader", "bh20seqanalyzer", "bh20simplewebuploader"], - package_data={"bh20sequploader": ["bh20seq-schema.yml", "bh20seq-options.yml", "validation/formats"], + package_data={"bh20sequploader": ["bh20seq-schema.yml", + "bh20seq-options.yml", + "bh20seq-shex.rdf", + "validation/formats"], }, install_requires=install_requires, extras_require={ |