aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 41 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..d4040c1
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,41 @@
+dnl timelock -- timed release encryption utility
+
+dnl Copyright (C) 2017 Arun I <arunisaac@systemreboot.net>
+
+dnl This file is part of timelock.
+
+dnl timelock is free software: you can redistribute it and/or modify
+dnl it under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation, either version 3 of the License, or
+dnl (at your option) any later version.
+
+dnl timelock is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+dnl GNU General Public License for more details.
+
+dnl You should have received a copy of the GNU General Public License
+dnl along with timelock. If not, see <http://www.gnu.org/licenses/>.
+
+dnl Initialize autoconf and automake
+AC_INIT(timelock, 0.1, arunisaac@systemreboot.net)
+AM_INIT_AUTOMAKE([foreign no-dist-gzip dist-xz])
+
+dnl Silence make
+AM_SILENT_RULES([yes])
+
+dnl Check for libm
+AC_CHECK_HEADERS(math.h, [], [AC_ERROR([math.h not found])])
+AC_SEARCH_LIBS(round, m, [], [AC_ERROR([libm not found])])
+
+dnl Check for libgcrypt
+AM_PATH_LIBGCRYPT
+
+dnl Check for boost preprocessor headers
+AC_CHECK_HEADERS(boost/preprocessor/seq.hpp, [], [AC_ERROR([Boost preprocessor headers not found])])
+
+dnl Config output headers
+AC_CONFIG_HEADERS([config.h])
+
+dnl Output Makefile
+AC_OUTPUT(Makefile)