aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..4f54ea8
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,27 @@
+# timelock -- timed release encryption utility
+
+# Copyright (C) 2017 Arun I <arunisaac@systemreboot.net>
+
+# This file is part of timelock.
+
+# timelock is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# timelock is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with timelock. If not, see <http://www.gnu.org/licenses/>.
+
+AM_CPPFLAGS = $(LIBGCRYPT_CFLAGS)
+AM_CFLAGS = -Wall -Wextra -Wpedantic
+LDADD = $(LIBGCRYPT_LIBS)
+
+bin_PROGRAMS = timelock
+timelock_SOURCES = timelock.c
+TESTS = test.sh
+EXTRA_DIST = README.org $(TESTS)