aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès2012-08-18 17:33:20 +0200
committerLudovic Courtès2012-08-18 17:33:20 +0200
commitd3a740cca088e6ec981e4b80a10f53fcfe094511 (patch)
treef0ca39878a87dad4df37017c4160186fae93e731 /tests/Makefile.am
parentf82c8c6eb54560737fef15383702816fabe47fb4 (diff)
downloadskribilo-d3a740cca088e6ec981e4b80a10f53fcfe094511.tar.gz
skribilo-d3a740cca088e6ec981e4b80a10f53fcfe094511.tar.lz
skribilo-d3a740cca088e6ec981e4b80a10f53fcfe094511.zip
build: Update test suite framework to Automake 1.12.
* tests/Makefile.am (TESTS_ENVIRONMENT): Use semi-colons. Move $(GUILE) invocation... (TEST_LOG_COMPILER): ... here. New variable.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 87d7641..b26700f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,9 @@
TESTS_ENVIRONMENT = \
- GUILE_AUTO_COMPILE=0 \
- GUILE_LOAD_COMPILED_PATH="$(top_builddir)/src/guile:$$GUILE_LOAD_COMPILED_PATH" \
+ GUILE_AUTO_COMPILE=0; \
+ GUILE_LOAD_COMPILED_PATH="$(top_builddir)/src/guile:$$GUILE_LOAD_COMPILED_PATH"; \
+ export GUILE_AUTO_COMPILE GUILE_LOAD_COMPILED_PATH;
+
+TEST_LOG_COMPILER = \
$(GUILE) -L $(top_srcdir)/src/guile -L $(top_builddir)/src/guile
TESTS = \