aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès2012-05-14 00:53:04 +0200
committerLudovic Courtès2012-05-14 01:02:48 +0200
commit648a70e8929c1cf63a6093c4a78fe459c03b7273 (patch)
tree338a83cdb32fc41fb5b32aa19b22f4a1f12c2db4 /tests/Makefile.am
parente47dcdb8340d6c24a7f20107b3f199a8f70020a8 (diff)
downloadskribilo-648a70e8929c1cf63a6093c4a78fe459c03b7273.tar.gz
skribilo-648a70e8929c1cf63a6093c4a78fe459c03b7273.tar.lz
skribilo-648a70e8929c1cf63a6093c4a78fe459c03b7273.zip
info: Fix prev/next pointers.
* src/guile/skribilo/ast.scm (ast-fold): Explicitly document as depth-first. * src/guile/skribilo/engine/info.scm (info-node): Support PREV and NEXT as false. (node-next+prev+top): Rewrite using `match' and `node-children'. * tests/Makefile.am (TESTS): Add `engines/info.test'. * tests/engines/info.test: New file.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 280875a..84cb0c9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -3,7 +3,11 @@ TESTS_ENVIRONMENT = \
GUILE_LOAD_COMPILED_PATH="$(top_builddir)/src/guile:$$GUILE_LOAD_COMPILED_PATH" \
$(GUILE) -L $(top_srcdir)/src/guile -L $(top_builddir)/src/guile
-TESTS = ast.test readers/rss-2.test resolve.test
+TESTS = \
+ ast.test \
+ resolve.test \
+ readers/rss-2.test \
+ engines/info.test
EXTRA_DIST = $(TESTS)