aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtes2006-01-15 22:09:56 +0000
committerLudovic Courtes2006-01-15 22:09:56 +0000
commitf66ef36a1c5a8c28e6a95ec9f6b19e20e914e42a (patch)
tree0644c3d0dfc71fc56f0bda852914437b48f5707e /configure.ac
parent1a1f3bebff6dee978d90c823aba2995922ad2af8 (diff)
parentc72a09b779b110b2e189ab2b1872eb89f568605c (diff)
downloadskribilo-f66ef36a1c5a8c28e6a95ec9f6b19e20e914e42a.tar.gz
skribilo-f66ef36a1c5a8c28e6a95ec9f6b19e20e914e42a.tar.lz
skribilo-f66ef36a1c5a8c28e6a95ec9f6b19e20e914e42a.zip
Introduced SRFI-3[45] conditions; cleaned up `evaluator.scm'.
* src/guile/skribilo/condition.scm: New. * src/guile/skribilo/Makefile.am (dist_guilemodule_DATA): Added `condition.scm'. * src/guile/skribilo/evaluator.scm (skribe-eval): Renamed to `evaluate-document'. (skribe-eval-port): Renamed to `evaluate-document-from-port'. (skribe-load-options): Renamed to `*load-options*', a fluid. (skribe-load): Renamed to `load-document'. Use SRFI-34 `raise' when a file is not found. (skribe-include): Renamed to `include-document'. Use `raise'. * src/guile/skribilo/utils/compat.scm (%skribe-known-files): New. (skribe-load): New. (skribe-include): New. (skribe-load-options): New. (skribe-eval): New. (skribe-eval-port): New. * src/skribilo.in: Invoke `call-with-skribilo-error-catch'. Added a copyright notice. * src/guile/skribilo.scm (doskribe): Use `evaluate-document-from-port', not `skribe-eval-port'. * configure.ac: Look for `(srfi srfi-35)'. * AUTHORS: Mention that most of the code comes from the STkLos implementation. git-archimport-id: lcourtes@laas.fr--2004-libre/skribilo--devel--1.2--patch-27
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb130d4..17f914d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,6 +14,9 @@ GUILE_SITE_DIR
# Need guile-reader 0.2.
GUILE_MODULE_REQUIRED([system reader])
+# Need SRFI-35, available in `guile-library'.
+GUILE_MODULE_REQUIRED([srfi srfi-35])
+
# Look for Lout.
AC_PATH_PROG([LOUT], [lout], [not-found])
AM_CONDITIONAL([HAVE_LOUT], [test "x$LOUT" != "xnot-found"])