aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès2020-08-01 12:49:29 +0200
committerLudovic Courtès2020-08-01 17:00:15 +0200
commitd183aa487d99baea3746f79759c17cf36c55dfbf (patch)
treec3cf9577d5f252e0c9f3fb30f780b0b75fb57b0f /configure.ac
parentddb2e47d8ed4d6d6508d342c0718492f99db64d4 (diff)
downloadskribilo-d183aa487d99baea3746f79759c17cf36c55dfbf.tar.gz
skribilo-d183aa487d99baea3746f79759c17cf36c55dfbf.tar.lz
skribilo-d183aa487d99baea3746f79759c17cf36c55dfbf.zip
build: Remove support for Guile 1.8.
* configure.ac: Remove "1.8" from 'GUILE_PKG'. Remove 'HAVE_GUILE2' conditional. Remove checks for (srfi srfi-34), (srfi srfi-35), and (srfi srfi-37). * guilec.am: Inline what was in HAVE_GUILE2 and remove the alternate. * src/guile/skribilo/debug.scm (debug-item): Remove 'cond-expand' and keep only the 'guile-2' variant. * src/guile/skribilo/engine.scm (engine-loaded?): Likewise. * src/guile/skribilo/lib.scm (&invocation-location, define-markup): Likewise. * src/guile/skribilo/utils/syntax.scm (%skribilo-module-reader): Likewise. * web/index.skb: Remove mention of 1.8. * README: Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 2 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 73cbc21..26b063d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,28 +45,14 @@ AC_PROG_LN_S
AC_PROG_MKDIR_P
# Look for Guile.
-GUILE_PKG([2.2 2.0 1.8])
+GUILE_PKG([2.2 2.0])
GUILE_PROGS
GUILE_SITE_DIR
-AC_PATH_PROGS([GUILD], [guild guile-tools])
-
-# GNU Guile 2.0.x and its compiler.
-AM_CONDITIONAL([HAVE_GUILE2],
- [test "x$GUILD" != "x" && \
- "$GUILD" compile --help >/dev/null 2>&1])
+AC_PATH_PROGS([GUILD], [guild])
# Need Guile-Reader.
GUILE_MODULE_REQUIRED([system reader])
-# SRFI-34 is normally in Guile 1.8, but let's make sure.
-GUILE_MODULE_REQUIRED([srfi srfi-34])
-
-# Need SRFI-35, available in Guile >= 1.8.3.
-GUILE_MODULE_REQUIRED([srfi srfi-35])
-
-# Need SRFI-37, available in Guile >= 1.8.3.
-GUILE_MODULE_REQUIRED([srfi srfi-37])
-
# Make sure we're not using the broken SRFI-35 from Guile-Lib <= 0.1.6.
SKR_GUILE_SRFI_35_WORKS