aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès2018-04-30 10:36:11 +0200
committerLudovic Courtès2018-04-30 10:36:11 +0200
commitacbd354ca0a32a5a551869a3650c9d265b83b204 (patch)
treec5d0a300353cd2a1d8033c6e336fa5f80866eb03 /configure.ac
parentbaa6c4c9288303cd227ebf7f777df16fdbc7abd0 (diff)
downloadskribilo-acbd354ca0a32a5a551869a3650c9d265b83b204.tar.gz
skribilo-acbd354ca0a32a5a551869a3650c9d265b83b204.tar.lz
skribilo-acbd354ca0a32a5a551869a3650c9d265b83b204.zip
build: Install modules and objects in the usual locations.v0.9.4
* configure.ac: Add '--with-guileobjectdir' and substitute 'guileobjectdir'. * guilec.am (nobase_nodist_module_DATA): Rename to... (nobase_nodist_guileobject_DATA): ... this (skr_install_go_files): Change value to 'install-nobase_nodist_guileobjectDATA'. * src/guile/Makefile.am (nobase_nodist_module_DATA): Change "+=" to "=". (nobase_nodist_module_DATA): Rename to... (nobase_nodist_guileobject_DATA): ... this. * src/skribilo.in (GUILE_LOAD_COMPILED_PATH): Use @guileobjectdir@. * substitute.am (substitute): Add @guileobjectdir@.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 15 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a71aad6..73cbc21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,15 @@ AC_ARG_WITH([guilemoduledir],
esac],
[guilemoduledir=""])
+AC_ARG_WITH([guileobjectdir],
+ [AS_HELP_STRING([--with-guileobjectdir=DIR],
+ [install Guile object files under DIR])],
+ [case "x$withval" in
+ xyes|xno) guileobjectdir="";;
+ *) guileobjectdir="$withval";;
+ esac],
+ [guileobjectdir=""])
+
AC_PROG_LN_S
AC_PROG_MKDIR_P
@@ -94,12 +103,15 @@ AM_CONDITIONAL([HAVE_PLOTICUS], [test "x$PLOTICUS" != "x"])
# Emacs.
AM_PATH_LISPDIR
-
-pkgdatadir="$datadir/$PACKAGE_TARNAME"
+dnl Installation directories for .scm and .go files.
if test "x$guilemoduledir" = "x"; then
- guilemoduledir="$pkgdatadir/$PACKAGE_VERSION"
+ guilemoduledir="${datarootdir}/guile/site/$GUILE_EFFECTIVE_VERSION"
+fi
+if test "x$guileobjectdir" = "x"; then
+ guileobjectdir="${libdir}/guile/$GUILE_EFFECTIVE_VERSION/site-ccache"
fi
AC_SUBST([guilemoduledir])
+AC_SUBST([guileobjectdir])
if test "$guilemoduledir" != "$GUILE_SITE"; then
# Guile won't be able to locate the modules "out of the box", so