aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès2007-12-03 09:17:21 +0100
committerLudovic Courtès2007-12-03 09:17:21 +0100
commita56a0ec33c367bc45c5adea83c95e74a080a89ab (patch)
tree4881e16d797f3a337163003c80f4a054a8f3388a /configure.ac
parentc37639aa4309ab680939cc0c1c7b211f96102721 (diff)
downloadskribilo-a56a0ec33c367bc45c5adea83c95e74a080a89ab.tar.gz
skribilo-a56a0ec33c367bc45c5adea83c95e74a080a89ab.tar.lz
skribilo-a56a0ec33c367bc45c5adea83c95e74a080a89ab.zip
configure: Have `guilemoduledir' default to `$pkgdatadir/$PACKAGE_VERSION'.
* configure.ac: Change default value of `guilemoduledir'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index dcb74cf..6d1230a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,15 +60,16 @@ AM_CONDITIONAL([HAVE_PLOTICUS], [test "x$PLOTICUS" != "x"])
pkgdatadir="$datadir/$PACKAGE_NAME"
if test "x$guilemoduledir" = "x"; then
- guilemoduledir="$pkgdatadir"
+ guilemoduledir="$pkgdatadir/$PACKAGE_VERSION"
fi
AC_SUBST([guilemoduledir])
if test "$guilemoduledir" != "$GUILE_SITE"; then
# Guile won't be able to locate the module "out of the box", so
- # warn the user.
+ # warn the user. OTOH, `skribilo' will find it, no matter where
+ # it is.
AC_MSG_WARN([`guilemoduledir' ($guilemoduledir) is different from `GUILE_SITE' ($GUILE_SITE).])
- AC_MSG_WARN([Make sure to adjust the `GUILE_LOAD_PATH' environment variable accordingly,])
+ AC_MSG_WARN([You might want to adjust the `GUILE_LOAD_PATH' environment variable accordingly,])
AC_MSG_WARN([or re-run `configure' with `--with-guilemoduledir=$GUILE_SITE'.])
fi