aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès2008-12-22 00:27:46 +0100
committerLudovic Courtès2008-12-22 00:27:46 +0100
commit7e57cd98570694f4630e8c34726af844e3981755 (patch)
treea565a99c4492d07be19f9a6bbcd60a3b00a263d9 /configure.ac
parent775eb2be66f67837ad4d41ba94ec0af164e863fe (diff)
downloadskribilo-7e57cd98570694f4630e8c34726af844e3981755.tar.gz
skribilo-7e57cd98570694f4630e8c34726af844e3981755.tar.lz
skribilo-7e57cd98570694f4630e8c34726af844e3981755.zip
Document dependency on SXML and HTMLPrag for the `rss-2' reader.
* configure.ac: Check for `(sxml simple)' and `(htmlprag)'. * README: Mention dependency on Guile-Lib.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 70e23c0..7d6d011 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,6 +50,12 @@ GUILE_MODULE_REQUIRED([srfi srfi-37])
# Make sure we're not using the broken SRFI-35 from Guile-Lib <= 0.1.6.
SKR_GUILE_SRFI_35_WORKS
+# Check for SXML and HTMLPrag from Guile-Lib, needed for the `rss-2' reader.
+GUILE_MODULE_AVAILABLE([have_sxml_simple], [(sxml simple)])
+GUILE_MODULE_AVAILABLE([have_htmlprag], [(htmlprag)])
+if test "x$have_sxml_simple$have_htmlprag" != "xyesyes"; then
+ AC_MSG_WARN([Guile-Lib modules needed by the `rss-2' reader are missing.])
+fi
# Look for `convert', from ImageMagick.
AC_PATH_PROG([CONVERT], [convert])