aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès2007-10-28 21:27:17 +0100
committerLudovic Courtès2007-10-28 21:27:17 +0100
commit7c2d4619be1893b25cdb8bf2165d23ee79f81241 (patch)
tree07dee662e4c352fb06e47814d218c93235f768e5 /configure.ac
parentfa27b2947ed2b144c9a0acccefaf412e687a3800 (diff)
downloadskribilo-7c2d4619be1893b25cdb8bf2165d23ee79f81241.tar.gz
skribilo-7c2d4619be1893b25cdb8bf2165d23ee79f81241.tar.lz
skribilo-7c2d4619be1893b25cdb8bf2165d23ee79f81241.zip
Modernized `configure.ac' a bit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 41c4b58..7ddb2be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,10 +3,14 @@
AC_PREREQ(2.59)
AC_INIT(skribilo, 1.2, skribilo-users@nongnu.org)
-AM_INIT_AUTOMAKE(skribilo, 1.2)
+AC_CONFIG_AUX_DIR(build-aux)
+AC_CONFIG_MACRO_DIR(m4)
+
+AM_INIT_AUTOMAKE([gnu no-define check-news])
AC_CONFIG_SRCDIR([src/guile/skribilo/reader.scm])
+
# GNU Gettext.
AM_GNU_GETTEXT([external])
@@ -20,10 +24,13 @@ AC_SUBST([GUILE_LINT])
AM_CONDITIONAL([HAVE_GUILE_LINT], test "x$GUILE_LINT" != "x")
-# Need guile-reader 0.2.
+# Need Guile-Reader.
GUILE_MODULE_REQUIRED([system reader])
-# Need SRFI-35, available in `guile-library'.
+# SRFI-34 is normally in Guile 1.8, but let's make sure.
+GUILE_MODULE_REQUIRED([srfi srfi-34])
+
+# Need SRFI-35, available in `guile-library' or Guile >= 1.8.3.
GUILE_MODULE_REQUIRED([srfi srfi-35])
# Look for Lout.