aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès2008-01-21 18:14:34 +0100
committerLudovic Courtès2008-01-21 18:14:34 +0100
commit5607c3d7c973fe2a63d346e891baf80b80b675ab (patch)
treeee1b0ce49e9e64fa6d2b3d1222e8211f533b474d /configure.ac
parent505c22d1ea6e299538b1c04e8a73f12045f2c793 (diff)
downloadskribilo-5607c3d7c973fe2a63d346e891baf80b80b675ab.tar.gz
skribilo-5607c3d7c973fe2a63d346e891baf80b80b675ab.tar.lz
skribilo-5607c3d7c973fe2a63d346e891baf80b80b675ab.zip
Improve configure message wrt. `guilemoduledir'.
* configure.ac: Use `AC_MSG_NOTICE' instead of `AC_MSG_WARN' when notifying the user of `guilemoduledir' different from `GUILE_SITE'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 8b7967a..7c27859 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,12 +70,13 @@ fi
AC_SUBST([guilemoduledir])
if test "$guilemoduledir" != "$GUILE_SITE"; then
- # Guile won't be able to locate the module "out of the box", so
- # warn the user. OTOH, `skribilo' will find it, no matter where
+ # Guile won't be able to locate the modules "out of the box", so
+ # warn the user. OTOH, `skribilo' will find them, no matter where
# it is.
- AC_MSG_WARN([`guilemoduledir' ($guilemoduledir) is different from `GUILE_SITE' ($GUILE_SITE).])
- AC_MSG_WARN([You might want to adjust the `GUILE_LOAD_PATH' environment variable accordingly,])
- AC_MSG_WARN([or re-run `configure' with `--with-guilemoduledir=$GUILE_SITE'.])
+ AC_MSG_NOTICE([`guilemoduledir' ($guilemoduledir) is different from `GUILE_SITE' ($GUILE_SITE).])
+ AC_MSG_NOTICE([There is nothing wrong with that, but to access Skribilo modules from Guile,])
+ AC_MSG_NOTICE([you will need, e.g., to adjust the `GUILE_LOAD_PATH' environment variable accordingly.])
+ AC_MSG_NOTICE([Alternatively, you can re-run `configure' with `--with-guilemoduledir=$GUILE_SITE'.])
fi