aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Court`es2007-02-02 17:15:33 +0000
committerLudovic Court`es2007-02-02 17:15:33 +0000
commit147a7fa8376429e78fe17f4a199c2394149c33a9 (patch)
treecbe534e61f8eef3131e877def6c090baceceeda8 /configure.ac
parent93c5157e92dc3506aa2b8fd1ab7c611a5f14eb6d (diff)
downloadskribilo-147a7fa8376429e78fe17f4a199c2394149c33a9.tar.gz
skribilo-147a7fa8376429e78fe17f4a199c2394149c33a9.tar.lz
skribilo-147a7fa8376429e78fe17f4a199c2394149c33a9.zip
Added basic GNU Gettext support.
* .arch-inventory: Mark `ABOUT-NLS' as precious. * Makefile.am (SUBDIRS): Added `po'. (ACLOCAL_AMFLAGS): New. (EXTRA_DIST): New. * configure.ac: Look for `gettext', output `po/Makefile.in'. * src/guile/skribilo/biblio/template.scm (make-bib-entry-template/default): Internationalized a bit. (make-bib-entry-template/skribe): Likewise. * src/guile/skribilo/utils/syntax.scm (%skribilo-module-reader): I18ned. (_): New. (N_): New. git-archimport-id: lcourtes@laas.fr--2006-libre/skribilo--devo--1.2--patch-11
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5774273..faab0bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,9 @@ AM_INIT_AUTOMAKE(skribilo, 1.2)
AC_CONFIG_SRCDIR([src/guile/skribilo/reader.scm])
+# GNU Gettext.
+AM_GNU_GETTEXT([external])
+
# Look for Guile.
GUILE_PROGS
GUILE_SITE_DIR
@@ -33,6 +36,7 @@ AC_SUBST([SKRIBILO_SKR_PATH], ["$GUILE_SITE/"])
AC_CONFIG_COMMANDS([skribilo-executable], [chmod a+x src/skribilo])
AC_OUTPUT([Makefile
+ po/Makefile.in
src/skribilo
src/Makefile
src/guile/Makefile