aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtes2005-10-31 23:26:24 +0000
committerLudovic Courtes2005-10-31 23:26:24 +0000
commit052c10245a523aa714489bda59e18a6c1a4f473e (patch)
tree36f6d93a9e53bb51342244d76ba4c965cf642ac4 /configure.ac
parent89a424521b753ee7c2c67ebdc957865657f647c4 (diff)
downloadskribilo-052c10245a523aa714489bda59e18a6c1a4f473e.tar.gz
skribilo-052c10245a523aa714489bda59e18a6c1a4f473e.tar.lz
skribilo-052c10245a523aa714489bda59e18a6c1a4f473e.zip
Installed Autoconf/Automake machinery. Fixed a few things.
* src/guile/skribilo/evaluator.scm (skribe-load): Search through `%load-path' and try with a `.scm' extension (rather than the `.skr' one provided by the user). (skribe-include): Added a few debugging statements. * src/guile/skribilo/lib.scm (fix-rest-arg): Handle the dot notation for rest arguments. * src/guile/skribilo/reader/skribe.scm (%make-skribe-reader): Use SQUARE-BRACKET-FREE-SYMBOL-MISC-CHARS. * src/guile/skribilo/skribe/index.scm: Use `define-public' instead of `define'. * src/guile/skribilo/packages/*.scm: Moved to `skribilo/package'. * LICENSE: Removed. * COPYING: New. * AUTHORS: New. * NEWS: New. * ChangeLog: New. * configure.ac: New. * Makefile.am: New. In various directories. git-archimport-id: lcourtes@laas.fr--2005-mobile/skribilo--devel--1.2--patch-10
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..a4bc494
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,36 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(skribilo, 1.2, ludovic.courtes@laas.fr)
+AM_INIT_AUTOMAKE(skribilo, 1.2)
+
+AC_CONFIG_SRCDIR([src/guile/skribilo/reader.scm])
+
+# Look for Guile.
+GUILE_PROGS
+GUILE_SITE_DIR
+
+# Need guile-reader 0.2.
+GUILE_MODULE_REQUIRED([system reader])
+
+# Look for Lout.
+AC_PATH_PROG([LOUT], [lout], [not-found])
+AM_CONDITIONAL([HAVE_LOUT], [test "x$LOUT" != "xnot-found"])
+
+AC_SUBST([SKRIBILO_DOC_DIR], ["$datadir/doc/skribilo"])
+AC_SUBST([SKRIBILO_EXT_DIR], ["$datadir/skribilo/1.2/"])
+AC_SUBST([SKRIBILO_SKR_PATH], ["$GUILE_SITE/"])
+
+AC_OUTPUT([Makefile
+ src/Makefile
+ src/guile/Makefile
+ src/guile/skribilo/Makefile
+ src/guile/skribilo/config.scm
+ src/guile/skribilo/engine/Makefile
+ src/guile/skribilo/reader/Makefile
+ src/guile/skribilo/package/Makefile
+ src/guile/skribilo/skribe/Makefile
+ src/guile/skribilo/coloring/Makefile
+ doc/Makefile
+ doc/user/Makefile])