aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 360b931..935c3b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,4 +30,10 @@ endforeach()
include_directories("include")
+include(GNUInstallDirs)
+
add_library(extentsampling SHARED ${C_SOURCES})
+set_target_properties(extentsampling PROPERTIES
+ PUBLIC_HEADER "include/extent-sampling.h;include/gaussian-nd-random.h;include/nd-random.h;include/oracles.h")
+install(TARGETS extentsampling LIBRARY
+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/extent-sampling)