aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 18 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 94264c7..fc3a296 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,8 +2,24 @@ cmake_minimum_required(VERSION 3.10)
project(extent-sampling VERSION 0.1)
find_package(GSL REQUIRED)
+# TODO: Make indent optional
+find_program(INDENT NAMES indent REQUIRED)
+find_program(SC NAMES sc REQUIRED)
+
+# Generate C source files from SC source files.
+file(GLOB SC_SOURCES "src/*.sc")
+foreach(sc_source ${SC_SOURCES})
+ get_filename_component(source_basename ${sc_source} NAME_WE)
+ set(c_file ${source_basename}.c)
+ add_custom_command(
+ OUTPUT ${c_file}
+ COMMAND ${SC} ${sc_source} ${c_file}
+ COMMAND ${INDENT} ${c_file}
+ DEPENDS ${sc_source}
+ VERBATIM)
+ list(APPEND C_SOURCES ${c_file})
+endforeach()
include_directories("include")
-file(GLOB SOURCES "src/*.c")
-add_library(extentsampling SHARED ${SOURCES})
+add_library(extentsampling SHARED ${C_SOURCES})