aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorArun Isaac2022-01-08 12:44:52 +0530
committerArun Isaac2022-01-08 13:02:05 +0530
commit81b49377edf2d5b08dca4b5ff3132499861244ea (patch)
tree9732533cbd870b0aa11a14c37b468e6ed1bfce45 /CMakeLists.txt
parent0ef42dfb41960ffa49aafc04fc7c9bfd49d13857 (diff)
downloadnsmc-81b49377edf2d5b08dca4b5ff3132499861244ea.tar.gz
nsmc-81b49377edf2d5b08dca4b5ff3132499861244ea.tar.lz
nsmc-81b49377edf2d5b08dca4b5ff3132499861244ea.zip
Bunch of unfinished experimentsunfinished-experiments
These experiments were in progress towards the end, and never properly finished. I leave the code here in case it turns out to be useful.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b4fae28..6701515 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,6 +75,12 @@ add_executable(integral integral.c)
target_link_libraries(integral nsmc -lm)
add_executable(spheroid spheroid.c)
target_link_libraries(spheroid nsmc)
+add_executable(centroid centroid.c)
+target_link_libraries(centroid nsmc)
+add_executable(whitening whitening.c)
+target_link_libraries(whitening nsmc -lm)
+add_executable(sample-on-ellipsoid sample-on-ellipsoid.c)
+target_link_libraries(sample-on-ellipsoid nsmc -lm)
# Build and install scheme wrapper.
if(${GUILE_FOUND})