aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--website/style.css20
2 files changed, 21 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1b71874..f0d256e 100644
--- a/Makefile
+++ b/Makefile
@@ -26,7 +26,7 @@ doc_skribilo_config_go = $(doc_skribilo_config:.scm=.go)
doc_sources = doc/forge.skb
doc_snippets = $(wildcard doc/snippets/*.scm)
doc_html = $(doc_sources:.skb=.html)
-fonts = $(addprefix $(GUIX_ENVIRONMENT)/share/fonts/web/, charter_regular.woff2)
+fonts = $(addprefix $(GUIX_ENVIRONMENT)/share/fonts/web/, charter_regular.woff2 FiraCode-Regular.woff2 FiraCode-SemiBold.woff2)
.PHONY: all html clean
all: ;
diff --git a/website/style.css b/website/style.css
index 5d8415c..bcd4136 100644
--- a/website/style.css
+++ b/website/style.css
@@ -5,6 +5,20 @@
font-style: normal;
}
+@font-face {
+ font-family: 'Fira Code';
+ src: url('/fonts/FiraCode-Regular.woff2') format('woff2');
+ font-weight: normal;
+ font-style: normal;
+}
+
+@font-face {
+ font-family: 'Fira Code';
+ src: url('/fonts/FiraCode-SemiBold.woff2') format('woff2');
+ font-weight: 600;
+ font-style: normal;
+}
+
body {
margin: 40px auto;
max-width: 900px;
@@ -14,13 +28,19 @@ body {
padding: 0 10px;
}
+pre, code, samp {
+ font-family: 'Fira Code';
+}
+
pre {
background-color: #f0f0f0;
padding: 1em;
+ font-size: 0.9em;
}
code, samp {
font-size: 0.8em;
+ font-weight: 600;
}
/* Make the SVG badges clickable. */