aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--guix/forge/git.scm43
-rw-r--r--guix/forge/klaus.scm30
2 files changed, 49 insertions, 24 deletions
diff --git a/guix/forge/git.scm b/guix/forge/git.scm
new file mode 100644
index 0000000..cd6fedc
--- /dev/null
+++ b/guix/forge/git.scm
@@ -0,0 +1,43 @@
+;;; guix-forge --- Guix software forge meta-service
+;;; Copyright © 2024 Arun Isaac <arunisaac@systemreboot.net>
+;;;
+;;; This file is part of guix-forge.
+;;;
+;;; guix-forge is free software: you can redistribute it and/or modify
+;;; it under the terms of the GNU General Public License as published
+;;; by the Free Software Foundation, either version 3 of the License,
+;;; or (at your option) any later version.
+;;;
+;;; guix-forge is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+;;; General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with guix-forge. If not, see
+;;; <https://www.gnu.org/licenses/>.
+
+(define-module (forge git)
+ #:use-module ((gnu packages version-control) #:select (git-minimal))
+ #:use-module (guix gexp)
+ #:use-module (guix packages)
+ #:use-module (guix utils))
+
+;; We serve shared repositories. But, git's safe directory check does
+;; not permit us to use shared repositories. Disable it.
+(define-public git-without-safe-directory-check
+ (package
+ (inherit git-minimal)
+ (name "git-without-safe-directory-check")
+ (arguments
+ (substitute-keyword-arguments (package-arguments git-minimal)
+ ((#:phases phases #~%standard-phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'disable-safe-directory-check
+ (lambda _
+ ;; Disable the safe directory check.
+ (substitute* "setup.c"
+ (("return data\\.is_safe;")
+ "return 1;"))
+ ;; Disable tests broken by this change.
+ (setenv "GIT_SKIP_TESTS" "t0033 t0411 t9700")))))))))
diff --git a/guix/forge/klaus.scm b/guix/forge/klaus.scm
index 5e5e3e0..cd9fa5f 100644
--- a/guix/forge/klaus.scm
+++ b/guix/forge/klaus.scm
@@ -19,6 +19,7 @@
(define-module (forge klaus)
#:use-module (forge environment)
+ #:use-module ((forge git) #:select (git-without-safe-directory-check))
#:use-module (forge gunicorn)
#:use-module (forge socket)
#:use-module ((gnu packages check) #:select (python-nose python-pytest))
@@ -26,7 +27,6 @@
#:select (python-flask python-werkzeug))
#:use-module ((gnu packages python-xyz)
#:select (python-dulwich python-humanize python-pygments))
- #:use-module ((gnu packages version-control) #:select (git-minimal))
#:use-module (gnu system file-systems)
#:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
@@ -34,7 +34,6 @@
#:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
- #:use-module (guix utils)
#:export (klaus-gunicorn-app))
(define-public python-httpauth
@@ -55,28 +54,6 @@
routes using HTTP Digest Authentication.")
(license license:bsd-2)))
-;; We use klaus to serve shared repositories. But, git's safe
-;; directory check does not permit us to use shared
-;; repositories. Disable it. The more long term solution is to rewrite
-;; klaus to not use the git CLI at all. See
-;; https://github.com/jonashaag/klaus/issues/322
-(define-public git-without-safe-directory-check
- (package
- (inherit git-minimal)
- (name "git-without-safe-directory-check")
- (arguments
- (substitute-keyword-arguments (package-arguments git-minimal)
- ((#:phases phases #~%standard-phases)
- #~(modify-phases #$phases
- (add-after 'unpack 'disable-safe-directory-check
- (lambda _
- ;; Disable the safe directory check.
- (substitute* "setup.c"
- (("return data\\.is_safe;")
- "return 1;"))
- ;; Disable tests broken by this change.
- (setenv "GIT_SKIP_TESTS" "t0033 t0411 t9700")))))))))
-
(define-public python-klaus
(package
(name "python-klaus")
@@ -104,6 +81,11 @@ routes using HTTP Digest Authentication.")
"tests/test_contrib.py"
"tests/test_make_app.py")))))))
(inputs
+ ;; We use klaus to serve shared repositories. But, git's safe
+ ;; directory check does not permit us to use shared
+ ;; repositories. Disable it. The more long term solution is to rewrite
+ ;; klaus to not use the git CLI at all. See
+ ;; https://github.com/jonashaag/klaus/issues/322
(list git-without-safe-directory-check))
(native-inputs
(list python-pytest))