aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorArun Isaac2022-01-08 21:50:35 +0530
committerArun Isaac2022-01-08 21:50:35 +0530
commitd81d606136df6543382f86cf8f3d1a8c66331079 (patch)
tree9c4404af9b4285d0f44ce03b0c0dac5fd2b071fc /Makefile
parentec7dc75811a65d8c6c6f3c626169e3c65f453fb1 (diff)
downloadguix-forge-d81d606136df6543382f86cf8f3d1a8c66331079.tar.gz
guix-forge-d81d606136df6543382f86cf8f3d1a8c66331079.tar.lz
guix-forge-d81d606136df6543382f86cf8f3d1a8c66331079.zip
website: Add website.
* Makefile, build-aux/build-home-page.el, website/style.css: New files.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..b4063c4
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,27 @@
+# guix-forge --- Guix software forge meta-service
+# Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
+#
+# This file is part of guix-forge.
+#
+# guix-forge is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# guix-forge is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with guix-forge. If not, see <https://www.gnu.org/licenses/>.
+
+EMACS = emacs
+
+.PHONY: all
+all: ;
+
+website: website/index.html
+
+website/index.html: README.org build-aux/build-home-page.el
+ $(EMACS) -Q --batch --load build-aux/build-home-page.el --funcall build-website