aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorArun Isaac2022-02-28 17:34:41 +0530
committerArun Isaac2022-02-28 18:11:03 +0530
commit6353f4af51d8a96763672734cc631ad41961b299 (patch)
tree867f9b6a029d2d118b557137942fe293c81b483e /Makefile
parent2cbbe1e1522638c1b380b3cc2008f1d4deb3d45e (diff)
downloadguix-forge-6353f4af51d8a96763672734cc631ad41961b299.tar.gz
guix-forge-6353f4af51d8a96763672734cc631ad41961b299.tar.lz
guix-forge-6353f4af51d8a96763672734cc631ad41961b299.zip
doc: Add Tutorial.
* Makefile (doc_snippets): New variable. ($(doc_html)): Depend on $(doc_snippets). * doc/forge.skb: Import (skribilo source lisp). (Tutorial): New chapter. * doc/snippets/tutorial.scm: New file.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 2fe0dd3..ef632bb 100644
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,7 @@ sources = $(wildcard forge/*.scm) $(wildcard forge/*/*.scm)
doc_skribilo_config = doc/skribilo.scm
doc_skribilo_config_go = $(doc_skribilo_config:.scm=.go)
doc_sources = doc/forge.skb
+doc_snippets = $(wildcard doc/snippets/*.scm)
doc_html = $(doc_sources:.skb=.html)
.PHONY: all html clean
@@ -34,7 +35,7 @@ all: ;
html: $(doc_html)
-$(doc_html): $(doc_sources) $(sources) $(doc_skribilo_config_go)
+$(doc_html): $(doc_sources) $(doc_snippets) $(sources) $(doc_skribilo_config_go)
rm -rf $@
mkdir -p $@
GUILE_LOAD_PATH=$(CURDIR):$(GUILE_LOAD_PATH) GUILE_LOAD_COMPILED_PATH=$(CURDIR):$(GUILE_LOAD_COMPILED_PATH) $(SKRIBILO) --target=html $< --output=$@/index.html