aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac2024-12-25 18:09:47 +0000
committerArun Isaac2024-12-25 18:11:36 +0000
commit4dac197c37a50923f4bdb21a5a2975b9ae8325ce (patch)
tree30a7321d89b6cb23ce1cf3b742a472fca3e92d25
parent9864821f976b3de355138c12f287a19fdced67df (diff)
downloadguix-forge-4dac197c37a50923f4bdb21a5a2975b9ae8325ce.tar.gz
guix-forge-4dac197c37a50923f4bdb21a5a2975b9ae8325ce.tar.lz
guix-forge-4dac197c37a50923f4bdb21a5a2975b9ae8325ce.zip
klaus: python-httpauth: Depend explicitly on setuptools and wheel.
Changes to pyproject-build-system require packages to depend explicitly on python-setuptools and python-wheel. * guix/forge/klaus.scm: Import python-setuptools and python-wheel from (gnu packages python-build). (python-httpauth)[native-inputs]: Add python-setuptools and python-wheel.
-rw-r--r--guix/forge/klaus.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/guix/forge/klaus.scm b/guix/forge/klaus.scm
index 6df3e08..23c554f 100644
--- a/guix/forge/klaus.scm
+++ b/guix/forge/klaus.scm
@@ -24,6 +24,8 @@
#:use-module (forge gunicorn)
#:use-module (forge socket)
#:use-module ((gnu packages check) #:select (python-nose python-pytest))
+ #:use-module ((gnu packages python-build)
+ #:select (python-setuptools python-wheel))
#:use-module ((gnu packages python-web)
#:select (python-flask python-werkzeug))
#:use-module ((gnu packages python-xyz)
@@ -48,7 +50,10 @@
(base32
"1m6rwvivg61l3h34hf6p6gkqmr69sb1c4k5ha379nxq0p8bfgahb"))))
(build-system pyproject-build-system)
- (native-inputs (list python-pytest))
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/jonashaag/httpauth")
(synopsis "WSGI HTTP Digest Authentication middleware")
(description "@code{python-httpauth} is WSGI middleware that secures some/all