aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart2024-07-25 15:27:43 -0500
committerArun Isaac2024-07-29 11:10:08 +0100
commit4766e45b4b15fb4dca2704e1f441467aa8688ae8 (patch)
tree783fbbcf2728cbb011a1c87ca08f2c3a0f31bf84
parentef8ae8df2b84a01e1751bfd47696dd14bdd8af9e (diff)
downloadguix-forge-4766e45b4b15fb4dca2704e1f441467aa8688ae8.tar.gz
guix-forge-4766e45b4b15fb4dca2704e1f441467aa8688ae8.tar.lz
guix-forge-4766e45b4b15fb4dca2704e1f441467aa8688ae8.zip
klaus: python-httpauth: Update to 0.4.1.
* guix/forge/klaus.scm (python-httpauth): Update to 0.4.1. [native-inputs]: Add python-pytest and remove python-nose. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--guix/forge/klaus.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/guix/forge/klaus.scm b/guix/forge/klaus.scm
index cd9fa5f..0cdba60 100644
--- a/guix/forge/klaus.scm
+++ b/guix/forge/klaus.scm
@@ -1,5 +1,6 @@
;;; guix-forge --- Guix software forge meta-service
;;; Copyright © 2023, 2024 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2024 jgart <jgart@dismail.de>
;;;
;;; This file is part of guix-forge.
;;;
@@ -39,15 +40,15 @@
(define-public python-httpauth
(package
(name "python-httpauth")
- (version "0.3")
+ (version "0.4.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "httpauth" version))
(sha256
(base32
- "0qas7876igyz978pgldp5r7n7pis8n4vf0v87gxr9l7p7if5lr3l"))))
+ "1m6rwvivg61l3h34hf6p6gkqmr69sb1c4k5ha379nxq0p8bfgahb"))))
(build-system pyproject-build-system)
- (native-inputs (list python-nose))
+ (native-inputs (list python-pytest))
(home-page "https://github.com/jonashaag/httpauth")
(synopsis "WSGI HTTP Digest Authentication middleware")
(description "@code{python-httpauth} is WSGI middleware that secures some/all